System Performance & Connectivity
Incident Report for Rightworks OneSpace
Resolved
This incident has been resolved.
Posted May 21, 2023 - 13:01 EDT
Investigating
We are currently experiencing higher than normal contact volume related to performance & connectivity of the Right Networks Hosted Desktop. Our engineers are working on identifying root cause and we will provide updates here as soon as they become available.
Posted May 21, 2023 - 11:38 EDT
This incident affected: Rightworks Application Cloud (Hosted Desktop, QuickBooks).